- html - 出于某种原因,IE8 对我的 Sass 文件中继承的 html5 CSS 不友好?
- JMeter 在响应断言中使用 span 标签的问题
- html - 在 :hover and :active? 上具有不同效果的 CSS 动画
- html - 相对于居中的 html 内容固定的 CSS 重复背景?
我在学习UVa 102 - Ecological Bin Packing问题:
Ecological Bin Packing
Background
Bin packing, or the placement of objects of certain weights into different bins subject to certain constraints, is an historically interesting problem. Some bin packing problems are NP-complete but are amenable to dynamic programming solutions or to approximately optimal heuristic solutions.
In this problem you will be solving a bin packing problem that deals with recycling glass.
The Problem
Recycling glass requires that the glass be separated by color into one of three categories: brown glass, green glass, and clear glass. In this problem you will be given three recycling bins, each containing a specified number of brown, green and clear bottles. In order to be recycled, the bottles will need to be moved so that each bin contains bottles of only one color.
The problem is to minimize the number of bottles that are moved. You may assume that the only problem is to minimize the number of movements between boxes.
For the purposes of this problem, each bin has infinite capacity and the only constraint is moving the bottles so that each bin contains bottles of a single color. The total number of bottles will never exceed 2^31.
The Input
The input consists of a series of lines with each line containing 9 integers. The first three integers on a line represent the number of brown, green, and clear bottles (respectively) in bin number 1, the second three represent the number of brown, green and clear bottles (respectively) in bin number 2, and the last three integers represent the number of brown, green, and clear bottles (respectively) in bin number 3.
For example, the line
10 15 20 30 12 8 15 8 31
indicates that there are 20 clear bottles in bin 1, 12 green bottles in bin 2, and 15 brown bottles in bin 3.Integers on a line will be separated by one or more spaces. Your program should process all lines in the input file.
The Output
For each line of input there will be one line of output indicating what color bottles go in what bin to minimize the number of bottle movements. You should also print the minimum number of bottle movements.
The output should consist of a string of the three upper case characters 'G', 'B', 'C' (representing the colors green, brown, and clear) representing the color associated with each bin.
The first character of the string represents the color associated with the first bin, the second character of the string represents the color associated with the second bin, and the third character represents the color associated with the third bin.
The integer indicating the minimum number of bottle movements should follow the string.
If more than one order of brown, green, and clear bins yields the minimum number of movements then the alphabetically first string representing a minimal configuration should be printed.
Sample Input
1 2 3 4 5 6 7 8 9
5 10 5 20 10 5 10 20 10
Sample Output
BCG 30
CBG 50
现在我卡住了...UVa 在线评判系统给了我 WA,但我不明白为什么。
以下是我的代码:
#include <stdio.h>
#include <stdlib.h>
int getSumOfBottles(int bottles[3][3]){
int i, j, sum;
for(i = 0; i < 3; i++){
for (j = 0; j < 3; j++){
sum += bottles[i][j];
}
}
return sum;
}
void showBGC(int inputNum){
switch (inputNum){
case 0:
printf("B");
break;
case 1:
printf("G");
break;
case 2:
printf("C");
break;
}
}
/* method 2*/
/* just use 6 kinds of posibilities to count*/
int main(int argc, char *argv[]) {
int i, j;
/* char array, with ', B == 0, G == 1, C ==2 */
char bcgText[3] = {'B', 'G', 'C'};
/* since BCG should show up in the begining, move {0, 2, 1} */
int posibleIndex[6][3] = {{0, 2, 1}, {0, 1, 2}, {1, 0, 2}, {1, 2, 0}, {2, 0, 1}, {2, 1, 0}};
int bottles[3][3];
int sumBottles;
int sumMove;
int minMove;
int minMoveIndex = 0;
while(scanf("%d%d%d%d%d%d%d%d%d", &bottles[0][0], &bottles[0][1], &bottles[0][2],
&bottles[1][0], &bottles[1][1], &bottles[1][2],
&bottles[2][0], &bottles[2][1], &bottles[2][2]) != EOF){
sumBottles = getSumOfBottles(bottles);
minMove = sumBottles;
/* get the moves in each cases, and find the minMovements */
for (i = 0; i < 6; i++){
sumMove = sumBottles - (bottles[0][posibleIndex[i][0]] + bottles[1][posibleIndex[i][1]] + bottles[2][posibleIndex[i][2]]);
if (sumMove < minMove){
minMove = sumMove;
minMoveIndex = i;
/* printf("index %d, minMove %d", i, minMove); */
}
}
/* one line output */
printf("%c%c%c %d\n", bcgText[posibleIndex[minMoveIndex][0]],
bcgText[posibleIndex[minMoveIndex][1]],
bcgText[posibleIndex[minMoveIndex][2]], minMove);
}
return 0;
}
有人可以给我一些提示吗?
最佳答案
您错过了“如果超过一个顺序的棕色、绿色和透明容器产生最少移动次数,则应打印代表最小配置的字母顺序第一个字符串。”您的 posibleIndex [6] [3] 初始化应该按照{{0, 2, 1}, {0, 1, 2}, {2,0,1}, {2,1,0}, {1, 0, 2}, {1, 2, 0} } 因为您已将 bcgText[3] 数组初始化为 { 'B', 'G', 'C'} 以保持字典顺序。还有一点,您应该将 getSumOfBottles 函数中声明的 sum 变量初始化为 0。尽管即使不初始化 sum 也会被接受,但这是一种不好的做法。
关于c - UVa 102 - Ecology Bin Packing 错误答案,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/31260839/
bin、bin/、bin/*和bin/**有什么区别我的 .gitignore 文件?我一直在使用 bin/,但正在查看 other .gitignore files (在 eclipse file
给定 n 个无限容量的箱子,我想将 m 件元素装入其中(每个元素都有特定的重量),同时最小化最重箱子的重量。 这不是传统的垃圾箱包装/背包问题,其中垃圾箱的容量有限,而您试图尽量减少使用的垃圾箱数量;
Closed. This question is off-topic。它当前不接受答案。 想改善这个问题吗? Update the question,所以它是用于堆栈溢出的on-topic。 7年前关
我一直在寻找一个问题的解决方案,这个问题显然比我最初想象的更不寻常。 Optaplanner 看起来很有前途,但由于我对 Java 相对缺乏经验,所以我想在深入研究之前调查一下这是否完全不可能。 我正
我有一个琐碎的问题。我有一个非常大的 df 有很多列。我正在尝试找到最有效的方法来对具有不同 bin 大小的所有列进行 bin 并创建一个新的 df。这是一个仅对单个列进行分箱的示例: import
我想以这样的方式对数字列 (var) 进行分类,使每个分类中的行数大致相同。我的附加要求是该列中的一个(唯一)值不能分配给多个 bin。例如,如果 var 列中的值 1 分配给 bin 1,则不允许将
我在 centos (rhel 7)_ 上使用 make 命令和 gcc 7.1 通过代码进行编译,但遇到了以下错误: /bin/sh:/bin: 是一个目录 which sh 返回/usr/bin/
/usr/bin/ld: cannot find -ldlib /usr/bin/ld: cannot find -lcblas /usr/bin/ld: cannot find -llapack 在
我进行了一项眼动追踪实验,试图检测两个区域(感兴趣区域,名为“代理”和“患者”的 AOI)的注视分布。我将整个时间划分为时间段,例如得到以下列表: Stimulus Participant A
我正在尝试替换 whoami带有 ~/.local/bin/ 中的脚本的命令.有没有办法让我的 whoami 获得优先权,这样当我运行 whoami 时,我的脚本就会运行? 最佳答案 这就是我的 ~/
我的项目结构是这样的: . ├── Cargo.lock ├── Cargo.toml └── src ├── bin │ └── other.rs ├── main.rs
我正在开发一个小型图书馆应用程序,它以这种格式存储技术手册: 目前,我正在尝试将库的内容保存并根据用户的需要加载到 bin 文件中。 但是,当我尝试加载库文件时,唯一的变化是“-1”被打印到控制台。此
我试图忽略 Web 项目的 bin 文件夹,但包含该 bin 文件夹中的 .refresh 文件。 这是我的 .gitignore 中的内容: [Bb]in/ #Allow .refresh file
ipv6_hdr__f_next_header_cp: coverpoint this.ipv6_hdr.ipv6_f_next_header iff (this.has_ipv6_header){
今天有人给我发了一个以 #: 开头的脚本,谷歌搜索后我没有找到任何答案。 即使脚本有效,我想知道那是什么意思。 最佳答案 哇!这让我想起了很多记忆! 回到 1980 年代和 90 年代初期,有两种基本
我使用这个 ksh 函数将“1-Jan-2011”格式转换为“1.1.2011”。 #!/bin/ksh ##---- function to convert 3 char month into nu
我在 c# winform 项目中使用 sql-server compact 数据库。 如果我查看构成解决方案的文件,我可以在以下两个文件夹中看到 exe 和 sdf 文件的副本: /bin/Debu
这个问题与我上一个问题不同。我正在通过以下代码使用 facetgrid 打印直方图。 import numpy as np import pandas as pd import seaborn as
我有一个整数需要根据概率分布分成 bin。例如,如果我有 N=100 对象进入 [0.02, 0.08, 0.16, 0.29, 0.45] 那么你可能会得到 [1, 10, 20 , 25, 44]
我在寻找使用 Jenkins 运行 Appium 的脚本时阅读了以下脚本 #!/bin/bash --login killall -9 "iPhone Simulator" &> /dev/null
我是一名优秀的程序员,十分优秀!