- html - 出于某种原因,IE8 对我的 Sass 文件中继承的 html5 CSS 不友好?
- JMeter 在响应断言中使用 span 标签的问题
- html - 在 :hover and :active? 上具有不同效果的 CSS 动画
- html - 相对于居中的 html 内容固定的 CSS 重复背景?
所以,我想做的是计算两点之间的距离。我得到了种子和要运行的模拟次数。我的代码可以运行,但不起作用?随机生成器不会生成数字并将其添加到数组中。我使用 r 为随机生成器播种,并使用 n 运行模拟。
编辑:在我通过控制台输入输入后,程序陷入循环它卡在行 X1[i] = rand.nextInt(1000);
处。
输入示例
2 --- t(待测试的巴黎数)
12087 400 --- r, n(r = 种子变量的数量,n = 运行 rand 的次数)
7418 978 --- r, n(第二个 r 和 n)
示例输入的示例输出 --- (这来自书中)
553.994525.789
通过这些数字,我们使用随机生成器来生成 X1、X2、Y1、Y2。这些数字将用于距离计算。
import java.io.*;
import java.util.*;
public class Distance {
public static void main(String[] args) {
double distance = 0; // initiates all numbers needed and sets to 0)
int r[] = new int[10];
int n[] = new int[10];
int X1[] = new int[10]; // Array initiations
int X2[] = new int[10];
int Y1[] = new int[10];
int Y2[] = new int[10];
Scanner q = new Scanner(System.in);
int t = q.nextInt(); // Scans in t (Number of lines to follow)
for (int i = 0; i < t; i++) {
r[i] = q.nextInt(); // Scans in r (Number of Random Objects)
n[i] = q.nextInt(); // Scans in n (Number of Simulations)
}
for (int i = 0; i < n[i]; i++) {
Random rand = new Random(r[i]);
X1[i] = rand.nextInt(n[i]); // fills index(s) i with Random number
// in X1 values
X2[i] = rand.nextInt(n[i]); // fills index(s) i with Random number
// in X2 values
Y1[i] = rand.nextInt(n[i]); // fills index(s) i with Random number
// in Y1 values
Y2[i] = rand.nextInt(n[i]); // fills index(s) i with Random number
// in Y2 values
distance = Math.sqrt(Math.pow((X2[i] - X1[i]), 2)
+ Math.pow((Y2[i] - Y1[i]), 2));
}
System.out.println(distance);
}
}
最佳答案
在第二个循环中,0 小于 t,因此循环控制变量没有执行任何操作。您需要将其更改为 i 小于 t,以便当 i 到达 t 时循环将结束。
这解决了您的无限循环问题,但我不确定您的程序是否正常工作。在第二个循环中,您每次都会替换 r 和 n,因此循环没有任何目的,因为 r 和 n 只会存储最后的输入。
使用以下代码修复此方法
for(int i = 0; i<t; i++) {
r = q.nextInt(); //Scans in r (Number of Random Objects)
n = q.nextInt(); //Scans in n (Number of Simulations)
}
如果我正确理解你的问题,我认为你正在尝试为每一对使用不同的 r 和 n 。为了实现这一点,我将使用一个数组来存储所有不同的 r 和 n 值。您的 print 语句也在最后一个 for 循环之外,因此您只能看到最后一对的结果。
import java.util.*;
公开课帮助{
public static void main(String[] args)
{
double distance = 0; //initiates all numbers needed and sets to 0)
int r[];
int n[];
int X1[];
int X2[];
int Y1[];
int Y2[];
Scanner q = new Scanner (System.in);
int t = q.nextInt(); //Scans in t (Number of lines to follow)
r = new int[t];
n = new int[t];
X1 = new int[t];
X2 = new int[t];
Y1 = new int[t];
Y2 = new int[t];
for(int i = 0; i<t; i++) {
r[i] = q.nextInt(); //Scans in r (Number of Random Objects)
n[i] = q.nextInt(); //Scans in n (Number of Simulations)
}
for(int i = 0; i < t; i++)
{
Random rand = new Random (r[i]);
X1[i] = rand.nextInt(n[i]); // fills index(s) i with Random number in X1 values
X2[i] = rand.nextInt(n[i]); // fills index(s) i with Random number in X2 values
Y1[i] = rand.nextInt(n[i]); // fills index(s) i with Random number in Y1 values
Y2[i] = rand.nextInt(n[i]); // fills index(s) i with Random number in Y2 values
distance = Math.sqrt( Math.pow((X2 [i] - X1 [i] ), 2) + Math.pow((Y2 [i] - Y1 [i] ), 2) );
System.out.println(distance);
}
}
}
关于java - 具有随机整数的距离公式。未产生输出,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/27156202/
我让随机数低于之前的随机数。 if Airplane==1: while icounter0: print "You have enoph fuel to get to New
是否可以生成 BigFloat 的随机数?类型均匀分布在区间 [0,1)? 我的意思是,因为 rand(BigFloat)不可用,看来我们必须使用 BigFloat(rand())为了那个结局。然而,
我正在尝试学习 Kotlin,所以我正在学习互联网上的教程,其中讲师编写了一个与他们配合良好的代码,但它给我带来了错误。 这是错误 Error:(26, 17) Kotlin: Cannot crea
是否有任何方法可以模拟 Collections.shuffle 的行为,而不使比较器容易受到排序算法实现的影响,从而保证结果的安全? 我的意思是不违反类似的契约(Contract)等.. 最佳答案 在
我正在创建一个游戏,目前必须处理一些math.random问题。 我的Lua能力不是那么强,你觉得怎么样 您能制定一个使用 math.random 和给定百分比的算法吗? 我的意思是这样的函数: fu
我想以某种方式让按钮在按下按钮时随机改变位置。我有一个想法如何解决这个问题,其中一个我在下面突出显示,但我已经认为这不是我需要的。 import javafx.application.Applicat
对于我的 Java 类(class),我应该制作一个随机猜数字游戏。我一直陷入过去几天创建的循环中。程序的输出总是无限循环,我不明白为什么。非常感谢任何帮助。 /* This program wi
我已经查看了涉及该主题的一些其他问题,但我没有在任何地方看到这个特定问题。我有一个点击 Web 元素的测试。我尝试通过 ID 和 XPath 引用它,并使用 wait.until() 等待它变得可见。
我在具有自定义类的字典和列表中遇到了该异常。示例: List dsa = (List)Session["Display"]; 当我使用 Session 时,转换工作了 10-20 次..然后它开始抛
需要帮助以了解如何执行以下操作: 每隔 2 秒,这两个数字将生成包含从 1 到 3 的整数值的随机数。 按下“匹配”按钮后,如果两个数字相同,则绿色标签上的数字增加 1。 按下“匹配”按钮后,如果两个
void getS(char *fileName){ FILE *src; if((src = fopen(fileName, "r")) == NULL){ prin
如果我有 2 个具有以下字段的 MySQL 数据库... RequestDB: - Username - Category DisplayDB: - Username - Category
我有以下语句 select random() * 999 + 111 from generate_series(1,10) 结果是: 690,046183290426 983,732229881454
我有一个使用 3x4 CSS 网格构建的简单网站。但出于某种原因,当我在 chrome“检查”中检查页面时,有一个奇怪的空白 显然不在我的代码中的标签。 它会导致网站上出现额外的一行,从而导致出现
我有两个动画,一个是“过渡”,它在悬停时缩小图像,另一个是 animation2,其中图像的不透明度以周期性间隔重复变化。 我有 animation2 在图像上进行,当我将鼠标悬停在它上面时,anim
如图所示post在 C++ 中有几种生成随机 float 的方法。但是我不完全理解答案的第三个选项: float r3 = LO + static_cast (rand()) /( static_c
我正在尝试将类添加到具有相同类的三个 div,但我不希望任何被添加的类重复。 我有一个脚本可以将一个类添加到同时显示的 1、2 或 3 个 div。期望的效果是将图像显示为背景图像,并且在我的样式表中
我有一个基本上可以工作的程序,它创建由用户设置的大小的嵌套列表,并根据用户输入重复。 但是,我希望各个集合仅包含唯一值,目前这是我的输出。 > python3 testv.py Size of you
我正在尝试基于 C# 中的种子生成一个数字。唯一的问题是种子太大而不能成为 int32。有什么方法可以像种子一样使用 long 吗? 是的,种子必须很长。 最佳答案 这是我移植的 Java.Util.
我写这个函数是为了得到一个介于 0 .. 1 之间的伪随机 float : float randomFloat() { float r = (float)rand()/(float)RAN
我是一名优秀的程序员,十分优秀!