- html - 出于某种原因,IE8 对我的 Sass 文件中继承的 html5 CSS 不友好?
- JMeter 在响应断言中使用 span 标签的问题
- html - 在 :hover and :active? 上具有不同效果的 CSS 动画
- html - 相对于居中的 html 内容固定的 CSS 重复背景?
所以我正在开发一个程序,该程序从文件中读取包含每行/项目的“商品编号”、“单价”和“购买日期”的行。我已经做到了可以扫描文件并以所需的图表格式组织它,但我不知道如何按“项目编号”对数据进行排序。
这是我的代码:
#include <stdio.h>
#include <stdlib.h>
int main() {
FILE *fp;
char ch;
fp = fopen("f.txt", "r"); //open the file named f.txt
if (fp == NULL) //In case we can't find the file, notify the user
printf("File not found\n");
printf("Item \t\tUnit Price\tPurchase Date\n"); //set up the header
while ((ch = fgetc(fp)) != EOF) { //set the character equal to the character next in the file using fgetc, and
//if its not equal to the end of file
if (ch == ',') {
printf("\t\t"); //add two tabs every time a ',' is encountered.
}
else {
printf("%c",ch); //just display the output from the file
}
}
fclose(fp); //closes the file
return 0;
}
示例输入
示例输出
看,我需要按项目编号(最左边的列)对输出进行排序。我的想法是将每一行添加到一个字符串数组(c 中的字符数组)中,然后从那里我不知道如何识别项目编号,以便对输出进行排序。我对 fscanf 有点熟悉,但不知道如何在这里应用它。非常感谢任何帮助,谢谢。
最佳答案
好吧,我相信将其分解为几个步骤会很好。
如果您不熟悉 strtok() 和 qsort() 函数,我强烈建议您阅读更多有关它们的内容。
这是代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
// STEP 1
typedef struct
{
int item;
float price;
char date[50];
} Data;
int compare (const void * a, const void * b)
{
Data *dataA = (Data *)a;
Data *dataB = (Data *)b;
return ( dataA->item - dataB->item ); // Ascending order
//return ( dataB->item - dataA->item ); // Descending order
}
int main()
{
FILE * fp;
char line[150];
Data data[3];
int i = 0;
fp = fopen("f.txt", "r");
while (1)
{
// STEP 2
if (fgets(line,150, fp) == NULL) break;
// STEP 3-4
char * pch;
pch = strtok (line,",");
data[i].item = atoi(pch); // item part
pch = strtok (NULL, ",");
data[i].price = atof(pch); // unit price part
pch = strtok (NULL, ",");
strcpy(data[i].date, pch); // purchase date part
i++;
}
printf("##### BEFORE #####\n");
printf("Item \t\tUnit Price\tPurchase Date\n"); //set up the header
for (int k = 0; k < 3; k++)
{
printf("%d\t\t%f\t%s", data[k].item, data[k].price, data[k].date);
}
// STEP 5
qsort (data, 3, sizeof(Data), compare);
printf("\n##### AFTER #####\n");
printf("Item \t\tUnit Price\tPurchase Date\n"); //set up the header
for (int k = 0; k < 3; k++)
{
printf("%d\t\t%f\t%s", data[k].item, data[k].price, data[k].date);
}
fclose(fp);
return 0;
}
请注意,此代码仅为您的测试用例而编写。如果您的数据结构不同(如果您有超过三列等),您需要修改代码。此外,您还需要进行更多的错误处理。
这是输出:
##### BEFORE #####
Item Unit Price Purchase Date
583 13.500000 10/24/2005
3912 599.989990 7/27/2008
12 19.990000 3/16/2001
##### AFTER #####
Item Unit Price Purchase Date
12 19.990000 3/16/2001
583 13.500000 10/24/2005
3912 599.989990 7/27/2008
希望这有帮助。
巴里斯
关于c - 对包含从 C 中的文件输入的数字的字符串进行排序?,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/47358051/
我想做的是让 JTextPane 在 JPanel 中占用尽可能多的空间。对于我使用的 UpdateInfoPanel: public class UpdateInfoPanel extends JP
我在 JPanel 中有一个 JTextArea,我想将其与 JScrollPane 一起使用。我正在使用 GridBagLayout。当我运行它时,框架似乎为 JScrollPane 腾出了空间,但
我想在 xcode 中实现以下功能。 我有一个 View Controller 。在这个 UIViewController 中,我有一个 UITabBar。它们下面是一个 UIView。将 UITab
有谁知道Firebird 2.5有没有类似于SQL中“STUFF”函数的功能? 我有一个包含父用户记录的表,另一个表包含与父相关的子用户记录。我希望能够提取用户拥有的“ROLES”的逗号分隔字符串,而
我想使用 JSON 作为 mirth channel 的输入和输出,例如详细信息保存在数据库中或创建 HL7 消息。 简而言之,输入为 JSON 解析它并输出为任何格式。 最佳答案 var objec
通常我会使用 R 并执行 merge.by,但这个文件似乎太大了,部门中的任何一台计算机都无法处理它! (任何从事遗传学工作的人的附加信息)本质上,插补似乎删除了 snp ID 的 rs 数字,我只剩
我有一个以前可能被问过的问题,但我很难找到正确的描述。我希望有人能帮助我。 在下面的代码中,我设置了varprice,我想添加javascript变量accu_id以通过rails在我的数据库中查找记
我有一个简单的 SVG 文件,在 Firefox 中可以正常查看 - 它的一些包装文本使用 foreignObject 包含一些 HTML - 文本包装在 div 中:
所以我正在为学校编写一个 Ruby 程序,如果某个值是 1 或 3,则将 bool 值更改为 true,如果是 0 或 2,则更改为 false。由于我有 Java 背景,所以我认为这段代码应该有效:
我做了什么: 我在这些账户之间创建了 VPC 对等连接 互联网网关也连接到每个 VPC 还配置了路由表(以允许来自双方的流量) 情况1: 当这两个 VPC 在同一个账户中时,我成功测试了从另一个 La
我有一个名为 contacts 的表: user_id contact_id 10294 10295 10294 10293 10293 10294 102
我正在使用 Magento 中的新模板。为避免重复代码,我想为每个产品预览使用相同的子模板。 特别是我做了这样一个展示: $products = Mage::getModel('catalog/pro
“for”是否总是检查协议(protocol)中定义的每个函数中第一个参数的类型? 编辑(改写): 当协议(protocol)方法只有一个参数时,根据该单个参数的类型(直接或任意)找到实现。当协议(p
我想从我的 PHP 代码中调用 JavaScript 函数。我通过使用以下方法实现了这一点: echo ' drawChart($id); '; 这工作正常,但我想从我的 PHP 代码中获取数据,我使
这个问题已经有答案了: Event binding on dynamically created elements? (23 个回答) 已关闭 5 年前。 我有一个动态表单,我想在其中附加一些其他 h
我正在尝试找到一种解决方案,以在 componentDidMount 中的映射项上使用 setState。 我正在使用 GraphQL连同 Gatsby返回许多 data 项目,但要求在特定的 pat
我在 ScrollView 中有一个 View 。只要用户按住该 View ,我想每 80 毫秒调用一次方法。这是我已经实现的: final Runnable vibrate = new Runnab
我用 jni 开发了一个 android 应用程序。我在 GetStringUTFChars 的 dvmDecodeIndirectRef 中得到了一个 dvmabort。我只中止了一次。 为什么会这
当我到达我的 Activity 时,我调用 FragmentPagerAdapter 来处理我的不同选项卡。在我的一个选项卡中,我想显示一个 RecyclerView,但他从未出现过,有了断点,我看到
当我按下 Activity 中的按钮时,会弹出一个 DialogFragment。在对话框 fragment 中,有一个看起来像普通 ListView 的 RecyclerView。 我想要的行为是当
我是一名优秀的程序员,十分优秀!