- html - 出于某种原因,IE8 对我的 Sass 文件中继承的 html5 CSS 不友好?
- JMeter 在响应断言中使用 span 标签的问题
- html - 在 :hover and :active? 上具有不同效果的 CSS 动画
- html - 相对于居中的 html 内容固定的 CSS 重复背景?
我正在尝试将本质上是获取一个输入文件并写出一个输出文件,该输出文件将输入的每个单词和标点符号放在单独的一行上。
示例输入:
System.out.println("hey there");
示例输出:
System.out.println
(
"hey
there"
)
;
这是我的代码:
import java.io.BufferedReader;
import java.io.BufferedWriter;
import java.io.IOException;
public class TokenSplitter {
private BufferedReader input;
private BufferedWriter output;
public TokenSplitter(BufferedReader input, BufferedWriter output) { //take our input and output
this.input = input;
this.output = output;
}
public void split() throws IOException {
while (input.readLine() != null) { //read each line
if (!input.readLine().isEmpty()) {
String currentLine = input.readLine();
for (int i = 0; i < currentLine.length(); i++) {
if (currentLine.length()>1) {
if ((currentLine.charAt(i) == '/' && (currentLine.charAt(i + 1) == '/' || (currentLine.charAt(i + 1) == '*')))
|| currentLine.charAt(1) == '*') {//locate if there are comments
currentLine = currentLine.substring(0, i);
}
}
}
currentLine.replaceAll(" ", "\n"); //new if there is a space, we know we finished a token
currentLine.replaceAll(";", "\n;");
currentLine.replaceAll("\\(", "\n(\n"); //with '(' we need to split before and after
currentLine.replaceAll("\\)", "\n)\n");
if (!currentLine.isEmpty()) {
output.write(currentLine + "\n");
}
}
}
我目前正在处理几个错误,但我主要的错误是\n 没有被插入到我的字符串中。基本上我的输出行打印出与我的输入行相同的长度,并且单词没有打印在不同的行上。任何人都知道为什么或如何解决它?
最佳答案
replaceAll
不会修改您调用它的字符串,它会返回一个新字符串。确保捕获其返回值。
currentLine = currentLine.replaceAll(" ", "\n");
currentLine = currentLine.replaceAll(";", "\n;");
currentLine = currentLine.replaceAll("\\(", "\n(\n");
currentLine = currentLine.replaceAll("\\)", "\n)\n");
(事实上 String
是不可变的,所以所有 String
方法都是如此。它们永远不会改变字符串。)
关于java - 关于 String 的 replaceAll 方法的困惑,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/28733538/
如果您想使用 String.Concat() 连接 5 个或更多字符串,则它会使用 Concat(String[])。 为什么不一直使用 Concat(String[]) 而不再需要 Concat(S
今天在使用 String 时,我遇到了一种我以前不知道的行为。我无法理解内部发生的事情。 public String returnVal(){ return "5";
似乎在我所看到的任何地方,都有一些过时的版本,这些版本不再起作用。 我的问题似乎很简单。我有一个Java类,它映射到derby数据库。我正在使用注释,并且已经成功地在数据库中创建了所有其他表,但是在这
一、string::size_type() 在C++标准库类型 string ,在调用size函数求解string 对象时,返回值为size_type类型,一种类似于unsigned类型的int 数据
我正在尝试将数据保存到我的 plist 文件中,其中包含字符串数组的定义。我的plist - enter image description here 我将数据写入 plist 的代码是 -- let
我有一个带有键/值对的 JavaScript 对象,其中值是字符串数组: var errors = { "Message": ["Error #1", "Error #2"], "Em
例如,为了使用相同的函数迭代 List 和 List> ,我可以编写如下内容: import java.util.*; public class Test{ public static voi
第一个Dictionary就像 Dictionary ParentDict = new Dictionary(); ParentDict.Add("A_1", "1")
这是我的 jsp 文件: 我遇到了错误 The method replace(String, String, String) in the type Functions is not appl
我需要一些帮助。我有一个方法应该输出一个包含列表内容的 txt 文件(每行中的每个项目)。列表项是字符串数组。问题是,当我调用 string.Join 时,它返回文字字符串 "System.Strin
一位同事告诉我,使用以下方法: string url = "SomeURL"; string ext = "SomeExt"; string sub = "SomeSub"; string s
给定类: public class CategoryValuePair { String category; String value; } 还有一个方法: public
我正在尝试合并 Stream>>对象与所有 Streams 中的键一起映射到单个映射中. 例如, final Map someObject; final List>> list = someObjec
在这里使用 IDictionary 的值(value)是什么? 最佳答案 使用接口(interface)的值(value)始终相同:切换到另一个后端实现时,您不必更改客户端代码。 请考虑稍后分析您的代
我可以知道这两个字典声明之间的区别吗? var places = [String: String]() var places = [Dictionary()] 为什么当我尝试以这种方式附加声明时,只有
在 .NET 4.0 及更高版本中存在 string.IsNullOrWhiteSpace(string) 时,在检查字符串时使用 string.IsNullOrEmpty(string) 是否被视为
这个名字背后的原因是什么? SS64在 PowerShell 中解释此处的字符串如下: A here string is a single-quoted or double-quoted string
我打算离开 this 文章,尝试编写一个接受字符串和 &str 的函数,但我遇到了问题。我有以下功能: pub fn new(t_num: S) -> BigNum where S: Into {
我有一个结构为 [String: [String: String]] 的多维数组。我可以使用 for 循环到达 [String: String] 位,但我不知道如何访问主键(这个位 [String:
我正在尝试使用 sarama(管理员模式)创建主题。没有 ConfigEntries 工作正常。但我需要定义一些配置。 我设置了主题配置(这里发生了错误): tConfigs := map[s
我是一名优秀的程序员,十分优秀!