- android - 多次调用 OnPrimaryClipChangedListener
- android - 无法更新 RecyclerView 中的 TextView 字段
- android.database.CursorIndexOutOfBoundsException : Index 0 requested, 光标大小为 0
- android - 使用 AppCompat 时,我们是否需要明确指定其 UI 组件(Spinner、EditText)颜色
我正在编写一个计算素数总和的程序。它必须使用重定向输入。我已经编写了它,以便它找到输入的最大数字,然后将其用作第 n 个素数。然后它使用第 n 个素数来设置数组的大小。它一直有效,直到我尝试打印总和。我不明白为什么我在所有地方都会遇到段错误。我想我已经用 malloc 正确地分配了数组。为什么故障会发生在 printf on 上,而不是在我使用我的数组时?也欢迎对我的代码提出任何建议。
编辑使用 2000 表单 1 到 2000 的测试输入并且它有效,但 10000 表单 1 到 10000 的完整测试文件崩溃仍在调查原因。我猜我没有分配足够的空间
编辑我的问题出在我的筛子上,我没有使用 sqrt(nthprime) 所以它找到了更多的素数然后数组可以容纳
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int nprime (int max);
void sieve_sum ( int *primes, int nthprime, int tests,int *input);
int main(void)
{
int i=0;
int max=0; //largest input
int tests; //number of tests
int nthprime; //estimated nth prime
int *primes; //array of primes
int *input; // numbers to put in to P(n), where p(n) is the summation of primes
scanf("%d",&tests); //gets number of tests
input = malloc(sizeof(int)*tests);
//test values
for(i=0; i<=tests-1; i++)
scanf("%d",&input[i]);
//finds max test value
i=0;
for (i = 0; i < tests; i++ )
{
if ( input[i] > max-1 )
max = input[i];
}
// calls nprime places value in n
nthprime = nprime(max);
primes = malloc(sizeof(int)*nthprime);
// calls sieve_sum
sieve_sum( primes, nthprime, tests, input);
//free memory
free(input);
free(primes);
return 0;
}
//finds Primes and their sum
void sieve_sum ( int *primes, int nthprime, int tests,int *input)
{
int i;
int j;
//fills in arrays with 1's
for(i=2; i<=nthprime; i++)
primes[i] = 1;
//replaces non primes with 0's
i=0;
for(i=2; i<=sqrt(nthprime); i++)
{
if(primes[i] == 1)
{
for(j=i; (i*j)<=(nthprime); j++)
primes[(i*j)] = 0;
}
}
//rewrites array with only primes
j=1;
i=0;
for(i=2; i<=nthprime; i++)
{
if(primes[i] == 1)
{
primes[j] = i;
j++;
}
}
//sums
i=0;
for ( i=1; i<=tests; i++ )
{
int sum=0;//sum of primes
j=0;
for(j=1; j<=input[i-1]; j++)
{
sum = primes[j] + sum;
}
printf("%d\n", sum );
}
return 0;
}
//finds the Nth number prime
int nprime (int max)
{
//aproximization of pi(n) (the nth prime) times 2 ensures correct allocation of memory
max = ceil( max*((log (max)) + log ((log (max)))))*2;
return (max);
}
示例输入文件:
20
1
2
3
4
5
6
7
8
9
10
10
9
8
7
6
5
4
3
2
1
示例输出应该是:
2
5
10
17
28
41
58
77
100
129
129
100
77
58
41
28
17
10
5
2
最佳答案
好吧,所以我要尝试一下,但不要说太多,因为看起来这可能是一个家庭作业问题。
我最好的猜测是,很多人甚至都回避查看您的代码,因为对于他们的耐心来说,代码有点太乱了。它不是不可挽回的,但如果它更干净一些,您可能会得到更好的响应。
因此,首先,对您的代码进行一些批评性评论以帮助您清理它:它没有充分充分地评论以明确您在任何级别的意图,包括该程序的总体目的是什么;它以非常规的方式不一致地缩进和间隔;并且您对变量名称的选择留下了一些不足之处,由于缺少对变量声明的注释而加剧了这种情况。
你应该用类似的东西编译这段代码(假设你的源文件名为 sumprimes.c
):
gcc -std=c99 -pedantic -Wall -Wextra -o sumprimes sumprimes.c -lm
看看它产生的警告,它会提醒您注意一些公认相当小的问题。
我可以通过检查看到的主要直接问题是您的程序肯定会出现段错误,因为您使用 malloc()
分配的存储空间太小了 sizeof( int)
,您已将其省略。
像splint 这样的静态错误检查器会帮助你发现一些进一步的问题;不过,没有必要盲目地遵循它的所有建议:一旦您理解它们,您就可以决定遵循哪些建议。
其他几点:
const int
或更传统的 #define
)以指示它的意义。 malloc()
的返回值不为NULL
,检查scanf()
的返回值(如果使用)是期望值等。scanf()
都是一个糟糕的选择,因为它以难以预测的方式改变 stdin
的状态,除非输入是 完全符合预期,这是您永远无法依赖的。如果您想读入一个整数,最好使用 fgets()
将 stdin
上可用的内容读入缓冲区,然后使用 strtol()
,因为您可以通过这种方式进行更有效的错误检查和报告。malloc()
的返回。希望这对您有所帮助。
关于c - 第 n 个素数的和,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/18519321/
我看到以下宏 here . static const char LogTable256[256] = { #define LT(n) n, n, n, n, n, n, n, n, n, n, n,
这个问题不太可能帮助任何 future 的访问者;它只与一个小的地理区域、一个特定的时间点或一个非常狭窄的情况有关,这些情况并不普遍适用于互联网的全局受众。为了帮助使这个问题更广泛地适用,visit
所以我得到了这个算法我需要计算它的时间复杂度 这样的 for i=1 to n do k=i while (k<=n) do FLIP(A[k]) k
n 的 n 次方(即 n^n)是多项式吗? T(n) = 2T(n/2) + n^n 可以用master方法求解吗? 最佳答案 它不仅不是多项式,而且比阶乘还差。 O(n^n) 支配 O(n!)。同样
我正在研究一种算法,它可以在带有变音符号的字符(tilde、circumflex、caret、umlaut、caron)及其“简单”字符之间进行映射。 例如: ń ǹ ň ñ ṅ ņ ṇ
嗯..我从昨天开始学习APL。我正在观看 YouTube 视频,从基础开始学习各种符号,我正在使用 NARS2000。 我想要的是打印斐波那契数列。我知道有好几种代码,但是因为我没有研究过高深的东西,
已关闭。这个问题是 off-topic 。目前不接受答案。 想要改进这个问题吗? Update the question所以它是on-topic用于堆栈溢出。 已关闭12 年前。 Improve th
谁能帮我从 N * N * N → N 中找到一个双射数学函数,它接受三个参数 x、y 和 z 并返回数字 n? 我想知道函数 f 及其反函数 f',如果我有 n,我将能够通过应用 f'(n) 来
场景: 用户可以在字符串格式的方程式中输入任意数量的括号对。但是,我需要检查以确保所有括号 ( 或 ) 都有一个相邻的乘数符号 *。因此 3( 应该是 3*( 和 )3 应该是 )*3。 我需要将所有
在 Java 中,表达式: n+++n 似乎评估为等同于: n++ + n 尽管 +n 是一个有效的一元运算符,其优先级高于 n + n 中的算术 + 运算符。因此编译器似乎假设运算符不能是一元运算符
当我阅读 this 问题我记得有人曾经告诉我(很多年前),从汇编程序的角度来看,这两个操作非常不同: n = 0; n = n - n; 这是真的吗?如果是,为什么会这样? 编辑: 正如一些回复所指出
我正在尝试在reveal.js 中加载外部markdown 文件,该文件已编写为遵守数据分隔符语法: You can write your content as a separate file and
我试图弄清楚如何使用 Javascript 生成一个随机 11 个字符串,该字符串需要特定的字母/数字序列,以及位置。 ----------------------------------------
我最近偶然发现了一个资源,其中 2T(n/2) + n/log n 类型 的递归被 MM 宣布为无法解决。 直到今天,当另一种资源被证明是矛盾的(在某种意义上)时,我才接受它作为引理。 根据资源(下面
关闭。此题需要details or clarity 。目前不接受答案。 想要改进这个问题吗?通过 editing this post 添加详细信息并澄清问题. 已关闭 8 年前。 Improve th
我完成的一个代码遵循这个模式: for (i = 0; i < N; i++){ // O(N) //do some processing... } sort(array, array + N
有没有办法证明 f(n) + g(n) = theta(n^2) 还是不可能?假设 f(n) = theta(n^2) & g(n) = O(n^2) 我尝试了以下方法:f(n) = O(n^2) &
所以我目前正在尝试计算我拥有的一些数据的 Pearson R 和 p 值。这是通过以下代码完成的: import numpy as np from scipy.stats import pearson
ltree 列的默认排序为文本。示例:我的表 id、parentid 和 wbs 中有 3 列。 ltree 列 - wbs 将 1.1.12, 1.1.1, 1.1.2 存储在不同的行中。按 wbs
我的目标是编写一个程序来计算在 python 中表示数字所需的位数,如果我选择 number = -1 或任何负数,程序不会终止,这是我的代码: number = -1 cnt = 0 while(n
我是一名优秀的程序员,十分优秀!