gpt4 book ai didi

c - 第 n 个素数的和

转载 作者:太空宇宙 更新时间:2023-11-04 06:33:06 28 4
gpt4 key购买 nike

我正在编写一个计算素数总和的程序。它必须使用重定向输入。我已经编写了它,以便它找到输入的最大数字,然后将其用作第 n 个素数。然后它使用第 n 个素数来设置数组的大小。它一直有效,直到我尝试打印总和。我不明白为什么我在所有地方都会遇到段错误。我想我已经用 malloc 正确地分配了数组。为什么故障会发生在 printf on 上,而不是在我使用我的数组时?也欢迎对我的代码提出任何建议。

编辑使用 2000 表单 1 到 2000 的测试输入并且它有效,但 10000 表单 1 到 10000 的完整测试文件崩溃仍在调查原因。我猜我没有分配足够的空间

编辑我的问题出在我的筛子上,我没有使用 sqrt(nthprime) 所以它找到了更多的素数然后数组可以容纳

#include <stdio.h>
#include <stdlib.h>
#include <math.h>


int nprime (int max);
void sieve_sum ( int *primes, int nthprime, int tests,int *input);

int main(void)
{
int i=0;
int max=0; //largest input
int tests; //number of tests
int nthprime; //estimated nth prime
int *primes; //array of primes
int *input; // numbers to put in to P(n), where p(n) is the summation of primes

scanf("%d",&tests); //gets number of tests
input = malloc(sizeof(int)*tests);

//test values
for(i=0; i<=tests-1; i++)
scanf("%d",&input[i]);

//finds max test value
i=0;
for (i = 0; i < tests; i++ )
{
if ( input[i] > max-1 )
max = input[i];
}

// calls nprime places value in n
nthprime = nprime(max);
primes = malloc(sizeof(int)*nthprime);

// calls sieve_sum
sieve_sum( primes, nthprime, tests, input);

//free memory
free(input);
free(primes);
return 0;
}

//finds Primes and their sum
void sieve_sum ( int *primes, int nthprime, int tests,int *input)
{
int i;
int j;

//fills in arrays with 1's
for(i=2; i<=nthprime; i++)
primes[i] = 1;

//replaces non primes with 0's
i=0;
for(i=2; i<=sqrt(nthprime); i++)
{
if(primes[i] == 1)
{
for(j=i; (i*j)<=(nthprime); j++)
primes[(i*j)] = 0;
}
}

//rewrites array with only primes
j=1;
i=0;
for(i=2; i<=nthprime; i++)
{
if(primes[i] == 1)
{
primes[j] = i;
j++;
}
}

//sums
i=0;
for ( i=1; i<=tests; i++ )
{
int sum=0;//sum of primes

j=0;
for(j=1; j<=input[i-1]; j++)
{
sum = primes[j] + sum;
}

printf("%d\n", sum );
}
return 0;
}

//finds the Nth number prime
int nprime (int max)
{
//aproximization of pi(n) (the nth prime) times 2 ensures correct allocation of memory
max = ceil( max*((log (max)) + log ((log (max)))))*2;
return (max);
}

示例输入文件:

20
1
2
3
4
5
6
7
8
9
10
10
9
8
7
6
5
4
3
2
1

示例输出应该是:

2 
5
10
17
28
41
58
77
100
129
129
100
77
58
41
28
17
10
5
2

最佳答案

好吧,所以我要尝试一下,但不要说太多,因为看起来这可能是一个家庭作业问题。

我最好的猜测是,很多人甚至都回避查看您的代码,因为对于他们的耐心来说,代码有点太乱了。它不是不可挽回的,但如果它更干净一些,您可能会得到更好的响应。

因此,首先,对您的代码进行一些批评性评论以帮助您清理它:它没有充分充分地评论以明确您在任何级别的意图,包括该程序的总体目的是什么;它以非常规的方式不一致地缩进和间隔;并且您对变量名称的选择留下了一些不足之处,由于缺少对变量声明的注释而加剧了这种情况。

你应该用类似的东西编译这段代码(假设你的源文件名为 sumprimes.c):

gcc -std=c99 -pedantic -Wall -Wextra -o sumprimes sumprimes.c -lm

看看它产生的警告,它会提醒您注意一些公认相当小的问题。

我可以通过检查看到的主要直接问题是您的程序肯定会出现段错误,因为您使用 malloc() 分配的存储空间太小了 sizeof( int),您已将其省略。

splint 这样的静态错误检查器会帮助你发现一些进一步的问题;不过,没有必要盲目地遵循它的所有建议:一旦您理解它们,您就可以决定遵循哪些建议。

其他几点:

  • “魔数(Magic Number)”,例如代码中的 100,被认为是非常糟糕的形式。根据经验,代码中唯一应该出现的数字是 0(零),而且只是偶尔出现。您的 100 最好表示为命名(如 const int 或更传统的 #define)以指示它的意义。
  • 以代码中的方式“减少”变量声明是非常规的
  • 如果一个函数被告知要返回一个值,您应该始终检查它是否有错误,例如确保malloc()的返回值不为NULL,检查scanf()的返回值(如果使用)是期望值等。
  • 作为一般的风格问题,C 通常认为每行声明一个变量并带有简短的解释性注释是一种很好的做法。也有异常(exception),但这是一个合理的经验法则。
  • 对于任何类型的输入,scanf() 都是一个糟糕的选择,因为它以难以预测的方式改变 stdin 的状态,除非输入是 完全符合预期,这是您永远无法依赖的。如果您想读入一个整数,最好使用 fgets()stdin 上可用的内容读入缓冲区,然后使用 strtol() ,因为您可以通过这种方式进行更有效的错误检查和报告。
  • 不建议再强制转换malloc()的返回。

希望这对您有所帮助。

关于c - 第 n 个素数的和,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/18519321/

28 4 0
Copyright 2021 - 2024 cfsdn All Rights Reserved 蜀ICP备2022000587号
广告合作:1813099741@qq.com 6ren.com