作者热门文章
- r - 以节省内存的方式增长 data.frame
- ruby-on-rails - ruby/ruby on rails 内存泄漏检测
- android - 无法解析导入android.support.v7.app
- UNIX 域套接字与共享内存(映射文件)
当我需要 slice 上的方法时,我必须声明一个新类型。但是我应该给它起什么名字呢?
type SliceSomething []Something
或 type SomethingSlice []Something
?
因为它被读作“某物的 slice ”,第一个似乎更好,但自动完成可能更喜欢第二个。
最佳答案
Variable names in Go should be short rather than long.
This is especially true for local variables with limited scope.
Preferc
tolineCount
. Preferi
tosliceIndex
.The basic rule: the further from its declaration that a name is used, the more descriptive the name must be.
这就是为什么您不会经常在 go 源代码中找到“Slice
”的原因,除了:
encoding/gob/encoder_test.go:335: type recursiveSlice []recursiveSlice
encoding/json/encode_test.go:107: type renamedByteSlice []byte
encoding/json/encode_test.go:108: type renamedRenamedByteSlice []renamedByte
regexp/onepass.go:283: type runeSlice []rune
sort/sort.go:233: type IntSlice []int
sort/sort.go:243: type Float64Slice []float64
sort/sort.go:258: type StringSlice []string
unicode/maketables.go:1118: type runeSlice []rune
因此,如果您必须在名称中放入“Slice
”,它将是type SomethingSlice []Something
而不是 type SliceSomething []Something
。
关于 slice 类型的 Go-地道命名,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/27987392/
我是一名优秀的程序员,十分优秀!